<!DOCTYPE html>
<html lang="en-US">
    <head>
        <meta charset="UTF-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="shortcut icon" href="/wp-content/uploads/2022/02/CNB-Favicon.png">
        <link rel="apple-touch-icon" href="/wp-content/uploads/2022/02/CNB-Favicon.png">
                <title>Managing Editor | Crestview News Bulletin</title>
<style>
#wpadminbar #wp-admin-bar-wccp_free_top_button .ab-icon:before {
	content: "\f160";
	color: #02CA02;
	top: 3px;
}
#wpadminbar #wp-admin-bar-wccp_free_top_button .ab-icon {
	transform: rotate(45deg);
}
</style>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//api-cdn.shutterstock.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Crestview News Bulletin &raquo; Feed" href="https://crestviewbulletin.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Crestview News Bulletin &raquo; Comments Feed" href="https://crestviewbulletin.com/comments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/crestviewbulletin.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='mp-theme-css'  href='https://crestviewbulletin.com/wp-content/plugins/memberpress/css/ui/theme.css?ver=1.9.27' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://crestviewbulletin.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='shutterstock-block-block-editor-shutterstock-ui-css-css'  href='https://api-cdn.shutterstock.com/2.0.2/static/css/sstk-widget.css?ver=5.9' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='shutterstock-css'  href='https://crestviewbulletin.com/wp-content/plugins/shutterstock/public/css/shutterstock-public.css?ver=1.3.10' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://crestviewbulletin.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='msl-main-css'  href='https://crestviewbulletin.com/wp-content/plugins/master-slider/public/assets/css/masterslider.main.css?ver=3.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='msl-custom-css'  href='https://crestviewbulletin.com/wp-content/uploads/master-slider/custom.css?ver=2.6' type='text/css' media='all' />
<link href="https://crestviewbulletin.com/wp-content/themes/yootheme/css/theme.1.css?ver=1645142455" rel="stylesheet">
<link href="https://crestviewbulletin.com/wp-content/themes/yootheme/css/theme.update.css?ver=2.7.3" rel="stylesheet">
<script type='text/javascript' src='https://api-cdn.shutterstock.com/2.0.2/static/js/sstk-widget.js?ver=5.9' id='shutterstock-block-block-editor-shuttestock-ui-js-js'></script>
<script type='text/javascript' src='https://crestviewbulletin.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://crestviewbulletin.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://crestviewbulletin.com/wp-content/plugins/shutterstock/public/js/shutterstock-public.js?ver=1.3.10' id='shutterstock-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/crestviewbulletin.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/crestviewbulletin.com\/wp-json\/wordpress-popular-posts","ID":24435,"token":"7c4ec717ed","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://crestviewbulletin.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.5.1' id='wpp-js-js'></script>
<script type='text/javascript' id='beehive-gtm-frontend-header-js-after'>
var dataLayer = [{"post_title":"Managing Editor"}];
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
			new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
			j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
			'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
			})(window,document,'script','dataLayer','GTM-K25C4BW');
</script>
<link rel="https://api.w.org/" href="https://crestviewbulletin.com/wp-json/" /><link rel="alternate" type="application/json" href="https://crestviewbulletin.com/wp-json/wp/v2/posts/24435" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://crestviewbulletin.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://crestviewbulletin.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9" />
<link rel='shortlink' href='https://crestviewbulletin.com/?p=24435' />
<link rel="alternate" type="application/json+oembed" href="https://crestviewbulletin.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcrestviewbulletin.com%2Fmanaging-editor%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://crestviewbulletin.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcrestviewbulletin.com%2Fmanaging-editor%2F&#038;format=xml" />
<script>var ms_grabbing_curosr = 'https://crestviewbulletin.com/wp-content/plugins/master-slider/public/assets/css/common/grabbing.cur', ms_grab_curosr = 'https://crestviewbulletin.com/wp-content/plugins/master-slider/public/assets/css/common/grab.cur';</script>
<meta name="generator" content="MasterSlider 3.8.1 - Responsive Touch Image Slider | avt.li/msf" />
<script id="wpcp_disable_selection" type="text/javascript">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</script>
<script id="wpcp_disable_Right_Click" type="text/javascript">
document.ondragstart = function() { return false;}
	function nocontext(e) {
	   return false;
	}
	document.oncontextmenu = nocontext;
</script>
<style>
.unselectable
{
-moz-user-select:none;
-webkit-user-select:none;
cursor: default;
}
html
{
-webkit-touch-callout: none;
-webkit-user-select: none;
-khtml-user-select: none;
-moz-user-select: none;
-ms-user-select: none;
user-select: none;
-webkit-tap-highlight-color: rgba(0,0,0,0);
}
</style>
<script id="wpcp_css_disable_selection" type="text/javascript">
var e = document.getElementsByTagName('body')[0];
if(e)
{
	e.setAttribute('unselectable',on);
}
</script>
<!-- SEO meta tags powered by SmartCrawl https://wpmudev.com/project/smartcrawl-wordpress-seo/ -->
<link rel="canonical" href="https://crestviewbulletin.com/managing-editor/" />
<meta name="description" content="Sandpaper Publishing, an award-winning, Northwest Florida community news organization, is seeking a managing editor that is passionate about journalism. Our ideal candidate is a creative and energetic leader that is enthusiastic about their role and purpose as an editor in our Northwest Florida ..." />
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"Organization","@id":"https:\/\/crestviewbulletin.com\/#schema-publishing-organization","url":"https:\/\/crestviewbulletin.com","name":"Crestview News Bulletin","logo":{"@type":"ImageObject","@id":"https:\/\/crestviewbulletin.com\/#schema-organization-logo","url":"https:\/\/crestviewbulletin.com\/wp-content\/uploads\/2022\/01\/SqureLogo.png","height":60,"width":60}},{"@type":"WebSite","@id":"https:\/\/crestviewbulletin.com\/#schema-website","url":"https:\/\/crestviewbulletin.com","name":"Crestview News Bulletin","encoding":"UTF-8","potentialAction":{"@type":"SearchAction","target":"https:\/\/crestviewbulletin.com\/search\/{search_term_string}\/","query-input":"required name=search_term_string"},"image":{"@type":"ImageObject","@id":"https:\/\/crestviewbulletin.com\/#schema-site-logo","url":"https:\/\/crestviewbulletin.com\/wp-content\/uploads\/2022\/01\/SqureLogo.png","height":341,"width":566}},{"@type":"WebPage","@id":"https:\/\/crestviewbulletin.com\/managing-editor\/#schema-webpage","isPartOf":{"@id":"https:\/\/crestviewbulletin.com\/#schema-website"},"publisher":{"@id":"https:\/\/crestviewbulletin.com\/#schema-publishing-organization"},"url":"https:\/\/crestviewbulletin.com\/managing-editor\/"},{"@type":"NewsArticle","mainEntityOfPage":{"@id":"https:\/\/crestviewbulletin.com\/managing-editor\/#schema-webpage"},"author":{"@type":"Person","@id":"https:\/\/crestviewbulletin.com\/author\/sandpapermarketingadmin\/#schema-author","name":"Melinda P","url":"https:\/\/crestviewbulletin.com\/author\/sandpapermarketingadmin\/"},"publisher":{"@id":"https:\/\/crestviewbulletin.com\/#schema-publishing-organization"},"dateModified":"2022-02-18T14:22:57","datePublished":"2022-02-18T14:11:01","headline":"Managing Editor | Crestview News Bulletin","description":"Sandpaper Publishing, an award-winning, Northwest Florida community news organization, is seeking a managing editor that is passionate about journalism. Our ideal candidate is a creative and energetic leader that is enthusiastic about their role and purpose as an editor in our Northwest Florida ...","name":"Managing Editor","image":{"@type":"ImageObject","@id":"https:\/\/crestviewbulletin.com\/managing-editor\/#schema-article-image","url":"https:\/\/crestviewbulletin.com\/wp-content\/uploads\/2022\/01\/SqureLogo.png","height":341,"width":566},"thumbnailUrl":"https:\/\/crestviewbulletin.com\/wp-content\/uploads\/2022\/01\/SqureLogo.png"}]}</script>
<meta property="og:type" content="article" />
<meta property="og:url" content="https://crestviewbulletin.com/managing-editor/" />
<meta property="og:title" content="Managing Editor | Crestview News Bulletin" />
<meta property="og:description" content="Sandpaper Publishing, an award-winning, Northwest Florida community news organization, is seeking a managing editor that is passionate about journalism. Our ideal candidate is a creative and energetic leader that is enthusiastic about their role and purpose as an editor in our Northwest Florida ..." />
<meta property="article:published_time" content="2022-02-18T14:11:01" />
<meta property="article:author" content="Melinda P" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Managing Editor | Crestview News Bulletin" />
<meta name="twitter:description" content="Sandpaper Publishing, an award-winning, Northwest Florida community news organization, is seeking a managing editor that is passionate about journalism. Our ideal candidate is a creative and energetic leader that is enthusiastic about their role and purpose as an editor in our Northwest Florida ..." />
<!-- /SEO -->
            <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>
            		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
							<!-- Google Analytics tracking code output by Beehive Analytics Pro -->
						<script async src="https://www.googletagmanager.com/gtag/js?id=UA-19894452-36&l=beehiveDataLayer"></script>
		<script>
						window.beehiveDataLayer = window.beehiveDataLayer || [];
			function beehive_ga() {beehiveDataLayer.push(arguments);}
			beehive_ga('js', new Date())
						beehive_ga('config', 'UA-19894452-36', {
				'anonymize_ip': false,
				'allow_google_signals': false,
			})
						beehive_ga('config', 'G-P1Q0B84YLW', {
				'anonymize_ip': false,
				'allow_google_signals': false,
			})
					</script>
		<script src="https://crestviewbulletin.com/wp-content/themes/yootheme/vendor/assets/uikit/dist/js/uikit.min.js?ver=2.7.3"></script>
<script src="https://crestviewbulletin.com/wp-content/themes/yootheme/vendor/assets/uikit/dist/js/uikit-icons-paladin.min.js?ver=2.7.3"></script>
<script src="https://crestviewbulletin.com/wp-content/themes/yootheme/js/theme.js?ver=2.7.3"></script>
<script>var $theme = {};</script>
<script> var _ctct_m = "3ac4b783d5bde4c28e4d49b325bcdae5"; </script>
<script id="signupScript" src="//static.ctctcdn.com/js/signup-form-widget/current/signup-form-widget.min.js" async defer></script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1371603/CNB-TopBanner', [728, 90], 'div-gpt-ad-1642697809883-0').addService(googletag.pubads());
          googletag.defineSlot('/1371603/CNB-300x250', [300, 250], 'div-gpt-ad-1642699043364-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
		<style type="text/css" id="wp-custom-css">
			figure {
  text-align: center;
	font-size: 9pt;	
  font-style: captiontext;
  text-indent: 0;
  margin: 0.5em;
  padding: 0.5em;
}		</style>
		    </head>
    <body class="post-template-default single single-post postid-24435 single-format-standard  _masterslider _ms_version_3.8.1 unselectable">
        
        
        
        <div class="tm-page">

                        
<div class="tm-header-mobile uk-hidden@m">


    <div class="uk-navbar-container">
        <nav uk-navbar="container: .tm-header-mobile">

                        <div class="uk-navbar-left">

                
                                <a class="uk-navbar-toggle" href="#tm-mobile" uk-toggle>
                    <div uk-navbar-toggle-icon></div>
                                    </a>
                
                
            </div>
            
                        <div class="uk-navbar-center">
                
<a href="https://crestviewbulletin.com" class="uk-navbar-item uk-logo">
    <img alt="Crestview News Bulletin" width="200" uk-svg  data-src="/wp-content/uploads/2022/01/CNB_LOGO.svg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img alt="Crestview News Bulletin" width="200" uk-svg src="/wp-content/uploads/2022/01/CNB_LOGO.svg"></noscript></a>
                            </div>
            
            
        </nav>
    </div>

    

<div id="tm-mobile" uk-offcanvas mode="slide" overlay>
    <div class="uk-offcanvas-bar">

                <button class="uk-offcanvas-close" type="button" uk-close></button>
        
        
            
<div class="uk-child-width-1-1" uk-grid>    <div>
<div class="uk-panel">

    
    
<ul class="uk-nav uk-nav-default">
    
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/subscribe/"> Subscribe</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://navarrepress-fl.newsmemory.com/"> E-Edition</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/job-board/"> Job Board</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home"><a href="https://crestviewbulletin.com/"> Home</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/news/"> News</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/community/"> Community</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/sports/"> Sports</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/beach/"> Outdoors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/crime/"> Crime</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/business/"> Business</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/education/"> Education</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/faith/"> Faith</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/fictitious-name/"> Fictitious Name</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/legal-notices/"> Legal Notices</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/obituaries/"> Obituaries</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/advertorial/"> Advertorial</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/archive/news/"> Archive</a></li></ul>

</div>
</div>    <div>
<div class="uk-panel widget widget_search" id="search-2">

    
    

    <form id="search-eb48" action="https://crestviewbulletin.com" method="get" role="search" class="uk-search uk-search-default"><span uk-search-icon></span><input name="s" placeholder="Search" required type="search" class="uk-search-input"></form>






</div>
</div></div>
            
    </div>
</div>

</div>


<div class="tm-toolbar tm-toolbar-default uk-visible@m">
    <div class="uk-container uk-flex uk-flex-middle">

        
                <div class="uk-margin-auto-left">
            <div class="uk-grid-medium uk-child-width-auto uk-flex-middle" uk-grid="margin: uk-margin-small-top">
                <div>
<div class="uk-panel widget widget_block" id="block-5">

    
    <a href="/job-board"><button class="uk-button uk-button-link">Job Board</button></a>
</div>
</div><div>
<div class="uk-panel widget widget_block" id="block-6">

    
    <a href="/obituaries"><button class="uk-button uk-button-link">Obituaries</button></a>
</div>
</div><div>
<div class="uk-panel widget widget_block" id="block-8">

    
    <a href="/legal-notices/"><button class="uk-button uk-button-link">Legal Notices</button></a>
</div>
</div><div>
<div class="uk-panel widget widget_block" id="block-9">

    
    <a href="/fictitious-name/"><button class="uk-button uk-button-link">Fictitious Name</button></a>
</div>
</div><div>
<div class="uk-panel widget widget_block" id="block-10">

    
    <a href="https://navarrepress-fl.newsmemory.com/?special=Crestview+News+Bulletin" target="_blank"><button class="uk-button uk-button-secondary">E-Edition</button></a>
</div>
</div><div>
<div class="uk-panel widget widget_block" id="block-11">

    
    <a href="/subscribe"><button class="uk-button uk-button-primary">Subscribe</button></a>
</div>
</div>            </div>
        </div>
        
    </div>
</div>

<div class="tm-header uk-visible@m" uk-header>





        <div class="tm-headerbar-default tm-headerbar tm-headerbar-top">
        <div class="uk-container">
            <div class="uk-position-relative uk-flex uk-flex-center uk-flex-middle">

                                <div class="uk-position-center-left tm-position-z-index-high">
                    <div class="uk-grid-medium uk-child-width-auto uk-flex-middle" uk-grid>
                        <div>
<div class="uk-panel widget widget_search" id="search-3">

    
    

    <form id="search-144d" action="https://crestviewbulletin.com" method="get" role="search" class="uk-search uk-search-default"><span uk-search-icon></span><input name="s" placeholder="Search" required type="search" class="uk-search-input"></form>






</div>
</div>                    </div>
                </div>
                
                
<a href="https://crestviewbulletin.com" class="uk-logo">
    <img alt="Crestview News Bulletin" width="600" uk-svg  data-src="/wp-content/uploads/2022/01/CNB-LOGO-Banner-2.svg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img alt="Crestview News Bulletin" width="600" uk-svg src="/wp-content/uploads/2022/01/CNB-LOGO-Banner-2.svg"></noscript></a>
                
                                <div class="uk-position-center-right tm-position-z-index-high">
                    <div class="uk-grid-medium uk-child-width-auto uk-flex-middle" uk-grid>
                                            </div>
                </div>
                
            </div>
        </div>
    </div>
    
    
                <div uk-sticky media="@m" cls-active="uk-navbar-sticky" sel-target=".uk-navbar-container">
        
            <div class="uk-navbar-container">

                <div class="uk-container">
                    <nav class="uk-navbar" uk-navbar="{&quot;align&quot;:&quot;left&quot;,&quot;boundary&quot;:&quot;.tm-header .uk-navbar-container&quot;,&quot;container&quot;:&quot;.tm-header &gt; [uk-sticky]&quot;}">

                        <div class="uk-navbar-center">
                            
<ul class="uk-navbar-nav">
    
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home"><a href="https://crestviewbulletin.com/"> Home</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/news/"> News</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/community/"> Community</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/crime/"> Crime</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/opinion/"> Opinion</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://crestviewbulletin.com/sports/"> Sports</a></li></ul>
                        </div>

                    </nav>
                </div>

            </div>

                </div>
        
    



</div>
            
            
<div id="tm-top" class="tm-top uk-section-default uk-section uk-section-xsmall">

    
        
        
        
                        <div class="uk-container">
            
                
                
<div class="uk-child-width-expand@m" uk-grid>    <div>
<div class="uk-panel widget widget_custom_html" id="custom_html-5">

    
    <div class="textwidget custom-html-widget"><!-- /1371603/CNB-TopBanner -->
<center><div id='div-gpt-ad-1642697809883-0' style='max-width: 728px; max-height: 90px;'>
	
	<script>  googletag.cmd.push(function() { googletag.display('div-gpt-ad-1642697809883-0'); });
	</script>
</div></center></div>
</div>
</div></div>
                        </div>
            
        
    
</div>

            
            <div id="tm-main"  class="tm-main uk-section uk-section-default" uk-height-viewport="expand: true">
                <div class="uk-container">

                    
                    <div class="uk-grid" uk-grid>
                        <div class="uk-width-expand@m">

                    
                            
            
<article id="post-24435" class="uk-article post-24435 post type-post status-publish format-standard hentry category-job-board" typeof="Article" vocab="https://schema.org/">

    <meta property="name" content="Managing Editor">
    <meta property="author" typeof="Person" content="SandpaperMarketingAdmin">
    <meta property="dateModified" content="2022-02-18T14:22:57-06:00">
    <meta class="uk-margin-remove-adjacent" property="datePublished" content="2022-02-18T14:11:01-06:00">

            
    
        
        <h1 property="headline" class="uk-margin-top uk-margin-remove-bottom uk-article-title">Managing Editor</h1>
                            <p class="uk-margin-top uk-margin-remove-bottom uk-article-meta">
                Written by <a href="https://crestviewbulletin.com/author/sandpapermarketingadmin/">SandpaperMarketingAdmin</a> on <time datetime="2022-02-18T14:11:01-06:00">February 18, 2022</time>.                Posted in <a href="https://crestviewbulletin.com/archive/job-board/" rel="category tag">Job Board</a>.                            </p>
                
        
        
                    <div class="uk-margin-medium-top" property="text">

                
                                    
<p>Sandpaper Publishing, an award-winning, Northwest Florida community news organization, is seeking a managing editor that is passionate about journalism.</p>



<p>Our ideal candidate is a creative and energetic leader that is enthusiastic about their role and purpose as an editor in our Northwest Florida community.</p>



<p>Do you have a passion for Journalism and believe in following the SPJ Code of Ethics? Can you write and produce compelling content and design across multiple platforms? Do you believe in FOIA? Are you willing to ask the hard questions and&nbsp;hold public officials accountable? Do you believe in local newspapers and the role they serve in a community? Do you want to make a difference? We are looking for an editor that has a passion for journalism and is not just in it for “a job” but believes in the purpose of our existence as journalists.</p>



<p>If you feel disillusioned by the current and unfortunately well-earned reputation of many in the mainstream news media and disappointed in the breakdown of ethics in your chosen career field, so are we. We believe journalist need to get down to their core existence and report the facts and not be “repeaters” instead of reporters. Journalists are not advocates. That is where “public relations” comes in and the career field a lot of &#8220;reporters&#8221; are moving to so they can at least be honest about the work they do. We keep our opinions on the editorial page and do not withhold news – which is another way of being an advocate instead of a journalist. If anything in this paragraph bothers you, then please do not apply for this position.</p>



<p>We are looking for a skilled Managing Editor to oversee our company’s daily publishing operations across all media platforms. You will be reporting to the publisher and supervise writers, editors and other staff as well as reporting.</p>



<p>A managing editor combines the innovativeness of a writer with the practical focus of an operations manager. You should be able to suggest ideas for stories and see them through to publication. We are looking for excellent organizational and leadership skills as well as a unique problem-solving ability.</p>



<p>The editor responsibilities comprise reviewing the written material and condensing and arranging it in a way to compel&nbsp;the reader to want to read further. While doing so, taking care that the given information and data is accurate, has good context, is valuable and relevant to the reader and&nbsp;is without bias, while legally compliant.</p>



<p><strong>Managing Editor (ME) Responsibilities Include:</strong></p>



<p>Responsible for reviewing, designing, correcting, editing, proof reading, and rewriting the content if necessary to provide a high-quality content. ME oversees the work of all the writers involved as well as that of the freelancers, guide them, and provide them with relevant feedback on their performance. They motivate them to give maximum quality output. They ensure that the material delivered is interesting and compelling keeping readers engaged in reading further and ensuring that the overall look/design of the newspaper is compelling to attract new readers, single copy purchasers who ultimately become subscribers. They also ensure that the content delivered is valuable, relevant and is within the given publication budget. Key responsibilities include but are not limited to:</p>



<ul><li>Planning and managing all daily operations including budgets/budgeting</li><li>Hiring, coaching and supervising personnel</li><li>Collaborating with publisher to determine issues’ content and topics and strategic direction</li><li>Coordinate editorial publications and meetings</li><li>Plan and approve assignments for writers and editors</li><li>Control schedules and enforce deadlines (for writers, photographers, designers etc.)</li><li>Oversee proofreading procedures and edit copy when necessary. To do thorough proof reading and editing of the written material by checking its writing style, grammar, fact checking etc.</li><li>Assist in evaluating finalized copy for compliance with policies, style and tone</li><li>Ensure that the writers are adhering by the rules and regulations of the organization and that it is in compliance with legal procedures</li><li>Ensure that copy editors/employees posting content to website/social/app adhere to ADA compliant practices to include HTML tagging making it easier for a screen reader to navigate; All images include alt text and creating usable links.</li><li>Resolve issues as they arise&nbsp;</li><li>Attend events on behalf of the company or publisher</li><li>Supervise the staff members, provide constructive feedback, and make recommendations for improving the quality of content and asking for re-writes as needed</li><li>Manage editorial page to include writing editorials, fair and equitable treatment of guest editorials and letters to the editors</li></ul>



<p><strong>Essential Skills/ Requirements Include:</strong></p>



<p>To ensure that you become a successful Managing Editor, it is essential that you have good understanding of the publication procedures, rules, regulations, and should be well-informed with the current developments in the industry. Should have excellent editing skills and have exceptional command over verbal and written communication skills. Must know when a legal boundary is about to be crossed. Our motto is, “When in doubt, keep it out.” Expect to deliver quality work on the given time, even when they are required to function under tight deadlines. Should be creative, self-motivated, self-driven, have attention to detail, and function independently as well as work in a team. Key skills/requirements include but are not limited to:</p>



<ul><li>Proven experience as managing editor or relevant role</li><li>Exceptional ability in copywriting and editing</li><li>Solid understanding and application of AP writing styles</li><li>Proficiency in English</li><li>Working knowledge of online platforms like WordPress and SEO concepts</li><li>Abilities in planning and coordinating people and operations</li><li>Excellent organizational and leadership skills</li><li>Outstanding communication and people abilities</li><li>Reliability and efficiency</li><li>Attention to detail</li><li>BS/BA in journalism or relevant field and/or equivalent work-related experience</li><li>Able to sit or stand in a stationary position for extended periods of time in meetings, covering court cases, etc. and/or sitting at computer editing, reviewing designs, page layouts and/or writing stories/editorials</li><li>Able to travel to and from story sources, community events and travel on company business as needed.</li><li>Constantly operates a computer and other office equipment.</li><li>Ability to work indoor and outdoor covering stories and events in various weather conditions.</li></ul>



<p><strong>Work Schedule:</strong><strong></strong></p>



<p>We have a casual, low ego, yet passionately dedicated work environment and competitive pay. We are members of America&#8217;s Newspapers and the Florida Press Association.</p>



<p>As you know, editors work at irregular hours as needed to deliver results in a pressure and a fast-paced work environment. Thus, may be required to work extra in the evenings or at nights. Sometimes, he/she may need to work on the weekends and public holidays. However, we do our best to make sure you aren’t “living at the office” even though we just consider it living because we love what we do.</p>



<p>A little bit about us:</p>



<p>Sandpaper Publishing, Inc. had one publication, Navarre Press, until January 1 of this year when we purchased two titles from Gannett, Santa Rosa Press Gazette and the Crestview News Bulletin. We are daily online and weekly in print with all three publications. Navarre Press almost 22-years old and has won best weekly newspaper in the state of Florida seven times. There are three “weight” classes so to speak, and last year we went to a higher circulation category and swept the awards. However, awards aren’t everything, in fact, they rank very low on our priority list.</p>



<p>Our Core Values:</p>



<p>-Excellence is our ordinary: We don’t do average – we only do extraordinary</p>



<p>-Personal Accountability: When there is a problem, you are part of the solution</p>



<p>-Passion &#8211; You either love it or leave it.</p>



<p>-We are not here for us: We are part of something much bigger than ourselves.</p>



<p>We are here to serve our community.</p>



<p>-There is no task beneath me.</p>



<p>Interested in Applying?</p>



<p>Please send us your resume and include a cover letter. Please tell us what you know about the Northwest Florida, a paragraph about why you are passionate about journalism and a links to at least three &#8211; five writing samples. The salary will be commensurate with experience, and we would like to pay someone a more than fair wage with demonstrated ability to meet our requirements.&nbsp; Wow us. Please your resume and cover letter to: <a href="mailto:jobs@sandpaperpublishing.com">jobs@sandpaperpublishing.com</a></p>
                
                
            </div>
        
        
        
        
                <ul class="uk-pagination uk-margin-medium">
                        <li><a href="https://crestviewbulletin.com/crestview-band-drops-four-new-singles/" rel="prev"><span uk-pagination-previous></span> Previous</a></li>
                                </ul>
        
        
    
</article>
        
                                                </div>

                        
<aside id="tm-sidebar" class="tm-sidebar uk-width-1-4@m">
    
<div class="uk-child-width-1-1" uk-grid>    <div>
<div class="uk-panel widget widget_block" id="block-2">

    
    <form role="search" method="get" action="https://crestviewbulletin.com/" class="wp-block-search__button-outside wp-block-search__text-button wp-block-search"><label for="wp-block-search__input-1" class="wp-block-search__label">Search</label><div class="wp-block-search__inside-wrapper " ><input type="search" id="wp-block-search__input-1" class="wp-block-search__input " name="s" value="" placeholder=""  required /><button type="submit" class="wp-block-search__button  " >Search</button></div></form>
</div>
</div>    <div>
<div class="uk-panel widget widget_block" id="block-3">

    
    <div class="wp-container-62100baed66c8 wp-block-group"><div class="wp-block-group__inner-container"><h2>Recent Posts</h2><ul class="wp-block-latest-posts__list wp-block-latest-posts"><li><a href="https://crestviewbulletin.com/managing-editor/">Managing Editor</a></li>
<li><a href="https://crestviewbulletin.com/crestview-band-drops-four-new-singles/">Crestview band drops four new singles</a></li>
<li><a href="https://crestviewbulletin.com/bulldogs-win-overtime-thriller-to-advance-in-playoffs/">Bulldogs win overtime thriller to advance in playoffs</a></li>
<li><a href="https://crestviewbulletin.com/hotel-employee-arrested-for-firing-weapon-inside-hotel-pending-termination/">Hotel employee arrested for firing weapon inside hotel, pending termination</a></li>
<li><a href="https://crestviewbulletin.com/crestview-band-releases-four-new-singles/">Crestview band releases four new singles</a></li>
</ul></div></div>
</div>
</div>    <div>
<div class="uk-panel widget widget_block" id="block-4">

    
    <div class="wp-container-62100baed6d67 wp-block-group"><div class="wp-block-group__inner-container"><h2>Recent Comments</h2><div class="no-comments wp-block-latest-comments">No comments to show.</div></div></div>
</div>
</div></div></aside>

                    </div>
                     
                </div>
            </div>
            
            
            <!-- Builder #footer -->
<div class="uk-section-default uk-section uk-section-xsmall">
    
        
        
        
            
                                <div class="uk-container">                
                    
                    <div class="tm-grid-expand uk-child-width-1-1 uk-margin-large" uk-grid>
<div class="uk-width-1-1@m">
    
        
            
            
                
                    
                
            
        
    
</div>
</div><div class="tm-grid-expand uk-child-width-1-1 uk-margin" uk-grid>
<div>
    
        
            
            
                
                    <hr class="uk-margin-remove-vertical">
<div class="uk-margin-small uk-text-center">
        <a class="el-link" href="https://crestviewbulletin.com/"><img width="300" class="el-image" alt="Crestview News Bulletin Logo" data-src="/wp-content/uploads/2022/01/CNB-LOGO-Banner-2.svg" uk-img></a>    
    
</div>

                
            
        
    
</div>
</div><div class="uk-margin-remove-top tm-grid-expand uk-margin-small uk-margin-remove-top" uk-grid>
<div class="uk-width-1-2@s uk-width-1-4@m">
    
        
            
            
                
                    
<ul class="uk-list">        <li class="el-item">
    <div class="uk-grid-small uk-child-width-expand uk-flex-nowrap uk-flex-middle" uk-grid>        <div class="uk-width-auto"><span class="el-image" uk-icon="icon: clock;"></span></div>        <div>
            <div class="el-content uk-panel uk-h6"><p>Monday - Friday<br />8:30 a.m. - 5:00 p.m.</p></div>        </div>
    </div>
</li>
        <li class="el-item">
    <div class="uk-grid-small uk-child-width-expand uk-flex-nowrap uk-flex-middle" uk-grid>        <div class="uk-width-auto"><a href="tel: 8506826524"><span class="el-image uk-text-secondary" uk-icon="icon: receiver;"></span></a></div>        <div>
            <div class="el-content uk-panel uk-h6"><a href="tel: 8506826524" class="el-link uk-link-muted uk-margin-remove-last-child"><h6><span>850.682.6524</span></h6></a></div>        </div>
    </div>
</li>
        <li class="el-item">
    <div class="uk-grid-small uk-child-width-expand uk-flex-nowrap uk-flex-middle" uk-grid>        <div class="uk-width-auto"><span class="el-image" uk-icon="icon: location;"></span></div>        <div>
            <div class="el-content uk-panel uk-h6"><p><span>638 N Ferdon Blvd <br />Crestview, FL 32536</span></p></div>        </div>
    </div>
</li>
    </ul>
                
            
        
    
</div>

<div class="uk-width-1-2@s uk-width-1-4@m">
    
        
            
            
                
                    
<ul class="uk-list uk-text-left">        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="/distribution" class="el-link uk-link-muted uk-margin-remove-last-child"><p>Distribution Locations</p></a></div></li>
        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="https://miltongazette.com/" target="_blank" class="el-link uk-link-muted uk-margin-remove-last-child"><p>Santa Rosa Press Gazette</p></a></div></li>
        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="https://navarrepress.com/" class="el-link uk-link-muted uk-margin-remove-last-child"><p style="text-align: left;">Navarre Press</p></a></div></li>
        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="https://hbtsnews.com/" target="_blank" class="el-link uk-link-muted uk-margin-remove-last-child"><p>HBTS News</p></a></div></li>
        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="https://navarrebeachnews.com/" target="_blank" class="el-link uk-link-muted uk-margin-remove-last-child"><p>Navarre Beach News</p></a></div></li>
    </ul>
                
            
        
    
</div>

<div class="uk-width-1-2@s uk-width-1-4@m">
    
        
            
            
                
                    
<ul class="uk-list uk-margin-medium uk-text-left">        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="/contact" class="el-link uk-link-muted uk-margin-remove-last-child"><p>Contact Us</p></a></div></li>
        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="/Obituaries" class="el-link uk-link-muted uk-margin-remove-last-child"><p>Obituaries</p></a></div></li>
        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="/legal-notices/" class="el-link uk-link-muted uk-margin-remove-last-child"><p>Legal Notices</p></a></div></li>
        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="/fictitious-name/" class="el-link uk-link-muted uk-margin-remove-last-child"><p>Fictitious Name</p></a></div></li>
        <li class="el-item">
    <div class="el-content uk-panel uk-h6"><a href="/letter-to-editor" class="el-link uk-link-muted uk-margin-remove-last-child"><p>Letter to Editor</p></a></div></li>
    </ul>
                
            
        
    
</div>

<div class="uk-width-1-2@s uk-width-1-4@m">
    
        
            
            
                
                    <div class="uk-panel uk-margin">
<div id="mepr-logged-out-template">
  <span class="mepr-link-span"><a href="https://crestviewbulletin.com/login/">Login</a></span>
</div>
</div>
                
            
        
    
</div>
</div><div class="uk-margin-remove-bottom tm-grid-expand uk-child-width-1-1 uk-margin-large uk-margin-remove-bottom" uk-grid>
<div class="uk-width-1-1@m">
    
        
            
            
                
                    <hr>
                
            
        
    
</div>
</div><div class="tm-grid-expand uk-margin" uk-grid>
<div class="uk-width-2-3@m">
    
        
            
            
                
                    <div class="uk-panel uk-margin uk-text-left@m uk-text-center"><p>© Copyright 2016-2026 Sandpaper Publishing, Inc. All Rights Reserved. <a href="/terms-of-service/">Terms of Service</a></p></div>
                
            
        
    
</div>

<div class="uk-width-1-3@m">
    
        
            
            
                
                    <div class="uk-panel uk-margin uk-text-right@m uk-text-center"><p>Designed by <a class="nonblock" href="http://sandpapermarketing.com/">Sandpaper Marketing</a></p></div>
                
            
        
    
</div>
</div>
                                </div>
                
            
        
    
</div>

        </div>

        
        	<div id="wpcp-error-message" class="msgmsg-box-wpcp hideme"><span>error: </span>Content is protected !!</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
		<style>
	@media print {
	body * {display: none !important;}
		body:after {
		content: "You are not allowed to print preview this page, Thank you"; }
	}
	</style>
		<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border:1px solid #f5aca6;
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
		.warning-wpcp {
		background:#ffecec url('https://crestviewbulletin.com/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
	}
    </style>

			<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":1,"name":"SandpaperMarketingAdmin","avatar":"538a84ad590aca696d43e8527b95af71"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '71612']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
					<noscript>
			<iframe  height="0" width="0" style="display:none;visibility:hidden" data-src="https://www.googletagmanager.com/ns.html?id=GTM-K25C4BW" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe>
		</noscript>
		<style>.wp-container-62100baed66c8 .alignleft { float: left; margin-right: 2em; }.wp-container-62100baed66c8 .alignright { float: right; margin-left: 2em; }</style><style>.wp-container-62100baed6d67 .alignleft { float: left; margin-right: 2em; }.wp-container-62100baed6d67 .alignright { float: right; margin-left: 2em; }</style><script type='text/javascript' src='https://crestviewbulletin.com/wp-content/plugins/wp-smush-pro/app/assets/js/smush-lazy-load.min.js?ver=3.9.6' id='smush-lazy-load-js'></script>
    </body>
</html>
